Picture of Sebastin Francis
Re: Preview of course not working CMD error message
by Sebastin Francis - Tuesday, 25 September 2018, 10:18 PM

Hi Daniel,

I'm an Instructional Designer, but a newbie to any coding/troubleshooting in terminal etc. I tried the following:

  • Installed pm2
  • When I received the preview error, tried "pm2 stop server", but got a "Process server not found" error.
  • I also tried saving to a different them, then revert to the vanilla theme
  • I could not save to a different menu as I had trouble installing anything other than the boxMenu

Would you happen to have any other pointers for me please? Or, if you could provide a more detailed steps ("for dummies!") for the first bullet point in your post, that would be awesome!

I would LOVE to get Adapt to work me as it would be a perfect tool for some of our mobile/microlearning lessons. I spent hours and days troubleshooting all the installation issues and got it working, only to get stuck at this preview error for the past couple of weeks! :(


I tried your fix (ensuring ffmpeg was working, then re-installed node, npm, grunt, adapt authoring tool) and ensured to update them, but no luck!

Thanks in advance for your help!