Picture of Marc Laskowski
Re: Error during installation process
by Marc Laskowski - Monday, 9 November 2020, 2:27 PM

I ran 'npm install jpegtran-bin' and get a success message:

> jpegtran-bin@5.0.2 postinstall /home/laskm/adapt_authoring/node_modules/jpegtran-bin
> node lib/install.js

✔ jpegtran pre-build test passed successfully
+ jpegtran-bin@5.0.2
added 131 packages from 29 contributors and audited 975 packages in 7.406s

But the error during the installation process is still the same. 

When I ran 'npm update', I receive the following output: 

npm WARN deprecated mkdirp@0.5.4: Legacy versions of mkdirp are no longer supported. Please update to mkdirp 1.x. (Note that the API surface has changed to use Promises in 1.x.)
+ async@3.2.0
+ inquirer@7.3.3
+ less@3.12.2
+ cookie-parser@1.4.5
+ connect-mongodb-session@2.4.1
+ express-session@1.17.1
+ mocha@6.2.3
+ grunt@1.3.0
+ mime@2.4.6
+ formidable@1.2.2
+ moment@2.29.1
+ morgan@1.10.0
+ underscore@1.11.0
+ nodemailer@6.4.15
+ needle@2.5.2
+ winston@3.3.3
+ unzipper@0.10.11
+ mongodb@3.6.3
+ mongoose@5.10.13
added 42 packages from 43 contributors, removed 16 packages, updated 50 packages and audited 1002 packages in 9.228s

28 packages are looking for funding
run `npm fund` for details

found 2 low severity vulnerabilities
run `npm audit fix` to fix them, or `npm audit` for details