Picture of Alison Ching
Authoring tool installation issue - help!
by Alison Ching - Wednesday, 24 March 2021, 8:48 PM

Hi, all -

Newbie here! I am trying to install the authoring tool on my computer, but I am having an issue. I am using a MacBook running Big Sur. I have very little experience with coding, but I was following the provided tutorial, and everything seemed to be working, until I got to step 3, Install the Required npm Packages.This is the error message I got when I ran the provided line of code (after clicking through the list of y/n questions).


Now we need to configure the master tenant.
Tip: just press ENTER to accept the default value in brackets.

error [24 Mar 21 15:30:31 -05:00] connect ECONNREFUSED
error [24 Mar 21 15:30:31 -05:00] failed to set app.db

Any suggestions? I would really appreciate it!




Picture of Chuck Lorenz
Re: Authoring tool installation issue - help!
by Chuck Lorenz - Wednesday, 24 March 2021, 11:10 PM

I suspect that Mongo is not running. Verify that the Mongo service is running; and if not, start it. Then rerun the

npm install --production


Did you install Mongo with Brew? Attached is a useful check list for Macs with Brew and for PCs. It was assembled by Laura Leonard. If it helps, all thanks go to her.

Picture of Alison Ching
Re: Authoring tool installation issue - help!
by Alison Ching - Thursday, 25 March 2021, 12:21 AM

That worked! Thank you so much!