Picture of Tracy Richardson
Installing theme
by Tracy Richardson - Thursday, 5 May 2016, 7:02 AM

Hi All,

I've been working in the authoring tool to build content, and I'm now onto theming my course.

I'm not sure what the recommended workflow is, but what I tried to do was download the source code, modify Vanilla, turn it into a new theme, then try uploading it back into the tool. I got as far as modifying Vanilla successfully and now I'm stuck.


Can I please have some help getting this theme to work with my content??


Here's what I tried:


1. I downloaded the source code for the course out of the authoring tool

2. Copied the 'node_modules' folder into the source code folder ('new-adapt-course') downloaded from the authoring tool so I could build it

2. I modified the 'contrib-vanilla' theme with updated less, hbr files and assets

3. Ran 'grunt build' and 'grunt server' to see the changes

All fine to this point.

I now want to rename my modified 'contrib-vanilla' to a new theme titled 'adapt-mynewtheme' and upload it back into the authoring tool.

I modified bower.json as described here: https://github.com/adaptlearning/adapt_authoring/wiki/Modifying-the-Vanilla-Theme and also renamed and updated theme/js/vanilla.js changing 'vanilla' to 'mynewtheme'.

This is where I run into trouble.

In order to test the new theme outside of the authoring tool, I then tried to uninstall Vanilla and install Mynewtheme using the command line as described here:


(cd to source code folder

adapt uninstall vanilla-contrib

adapt install mynewtheme

grunt build)

Running the uninstall command, it returns 'Oh dear, something went wrong. Package adapt-contrib-vanilla not found'... so of course installing the new theme doesn't work either.

Zipping the new theme up and uploading it to the authoring tool doesn't work either.


Help please! How can I apply my own theme and get it back into the authoring tool?



Additional info:

I tried referencing various sub directories of 'new-adapt-course' (didn't work)

I tried applying the theme to a course I started when I was only working with the framework, not the authoring tool. I could successfully uninstall 'contrib-vanilla' using the command line as described above but I couldn't successfully install 'mynewtheme'. The error returned first indicates it's not compatible with this version of the framework then returns the same error as before:

'Oh dear, something went wrong. Package mynewtheme not found'


Thanks very much for your help!!