Picture of paul diaper
Re: ffmpeg installation not working
by paul diaper - Tuesday, 11 September 2018, 12:58 PM

Finally got ffmpeg working and the thumbnails now appear.

To sum up:

Be sure to install the correct version of Node.
Install Grunt.
Make sure you say yes to ffmpeg installation when asked in the Adapt installation process.

Also you can set the Path for the ffmpeg via System Control Panel (Windows 10), instead of using Setx.

System Control Panel > Advanced System Settings > Advanced > Environment Variables... > System variables > Path > Edit

Remember to only add the path from drive letter to the ffmpeg folder and don't include ;%PATH% at the end.

(Don't replace any existing paths in the Path environment variable, just add a new path to the existing list in the variable for ffmpeg)

Finally I think John Niezen made an important point about thumbnails only appearing after ffmpeg is installed and Adapt is run again, previously uploaded media won't show up as thumbnails.