Picture of Troy Ashman
Authoring Tool - Preview not working
by Troy Ashman - Tuesday, 23 August 2016, 8:28 PM

Hi all,

I'm not 100% sure where to post this, so my apologises in advance if this is in the wrong section. I have recently got the Adapt Authoring Tool on my Mac OS and am playing around with the tool, watching some Learning Pool Webinar's to learn etc.

I have made a dummy course with some pages, blocks, articles and components - I wanted to test how I've gone etc. The preview button in my Adapt Authoring Tool is not working? When I click the button, it changes to Previewing... and just doesn't preview? 

I've also tried to download the dummy course I made and have tried to open the index.html file to test. All I'm presented with is a loading screen which never ends?

Hopefully someone can help me out? Thanks!

Picture of Derek Chirnside
Re: Authoring Tool - Preview not working
by Derek Chirnside - Tuesday, 23 August 2016, 11:13 PM

Well done for getting this far!!  Getting the builder up and running is not trivial.

Do you have any error logs you can look at?  Are you sure there is not an error somewhere?

I used the App.adaptbuilder.io and had a similar problem.  The issue was with the server, and some sort of space permissions problem.  That was solved and worked fine.


Picture of Troy Ashman
Re: Authoring Tool - Preview not working
by Troy Ashman - Wednesday, 24 August 2016, 8:27 PM

Hi Derek, thanks for your help! Definitely been an experience so far, but I love it.

I am using the Adapt Authoring Tool which I've downloaded/ installed via the GitHub / virtual server etc.

I'm not the best with error logs etc. But, I tried looking at them for the quick course I put together when playing around and got:

[Error] Failed to load resource: The requested URL was not found on this server. (css, line 0)
[Error] XMLHttpRequest cannot load file:///Users/xxx/Downloads/how-to-tie-a-bow-tie/course/config.json. Cross origin requests are only supported for HTTP.

Thanks for your help, sorry, not the best with this stuff??


Picture of Troy Ashman
Re: Authoring Tool - Preview not working
by Troy Ashman - Friday, 26 August 2016, 11:49 AM

Just seeing in there is any news on this or anything I can do to fix this?

I can't move forward as I can't preview / download and open the courses I'm trying to make.


Picture of Troy Ashman
Re: Authoring Tool - Preview not working
by Troy Ashman - Saturday, 27 August 2016, 4:27 AM

I have now also completed a fresh reinstall of the authoring tool via the git clone. I am still occurring this error where I cannot preview the courses nor download /view them.



Picture of Troy Ashman
Re: Authoring Tool - Preview not working
by Troy Ashman - Monday, 29 August 2016, 8:27 PM

Okay! So, I've managed to get the preview working! :) Somehow, Safari was blocking the pop-up but not alerting me there was a pop-up. I have no installed Google Chrome and am using the authoring tool through Chrome to develop and preview.

My only issue is now, I can't get the index.html file to open or work? I am present with this error (which I believe has something to do with file authority access????):


jquery.v2.js:4 XMLHttpRequest cannot load file:///Users/troyashman/Downloads/troy-ashman-resume/course/config.json. Cross origin requests are only supported for protocol schemes: http, data, chrome, chrome-extension, https, chrome-extension-resource.

Any help?


Picture of Helen Bailey
Re: Authoring Tool - Preview not working
by Helen Bailey - Friday, 2 September 2016, 9:00 AM

Was too late to tell you it was a pop-up problem!

As far as I'm aware you can't open and use index.html - you need to load the file into an LMS or scorm cloud type site to view it. That's why we have the Preview function, so you can see the course as it is?


Picture of Sean Wordingham
Re: Authoring Tool - Preview not working
by Sean Wordingham - Wednesday, 3 May 2017, 8:52 AM

Thanks very much Troy!  I was having the same problem with Preview and now it works :)

can open the index.html page using Chrome.  The video doesn't play, but apart from that it seems roughly the same as the preview.  I'm afraid I don't know what your error message mens though.

Picture of Matt Leathes
Re: Authoring Tool - Preview not working
by Matt Leathes - Wednesday, 3 May 2017, 10:39 AM

Trying to run web content from the file system is never a good idea; as you're discovering, most browsers' local security protocols will block a lot of the functionality.

There are ways around this but they differ from browser to browser and it's always difficult to be sure whether the settings you have applied work or not - far easier just to run the course from a web server.

As Helen points out, that's why there's a preview function built into the authoring tool.

If you do need to use something else then you could try:

If you're running Windows you could enable the IIS feature of Windows; if you're running macOS has Apache pre-installed, it's just that finding it and switching it on is not as easy as it used to be.