Picture of Amy Palmer
iFrames and IE11
by Amy Palmer - Thursday, 19 January 2017, 4:18 PM


I am trying to embed a Typeform quiz via iFrame into my Adapt course. The iFrame works fine in Chrome and Firefox, but won't even let the page load when I try it in IE11.

Even when I use the default frame that comes as part of the component (adapt-contrib-responsiveIframe) it won't load the page... 

The console is pointing here (but states it is line 403 that is causing the error): 


My javascript knowledge is non-existent so if anyone had any advice at all I would greatly appreciated it!

I think I just need to set the height and width but aren't sure where..


Picture of Matt Leathes
Re: iFrames and IE11
by Matt Leathes - Thursday, 19 January 2017, 6:44 PM

Hi Amy

The adapt-contrib-responsiveIFrame component does have settings for height and width, have you made sure they are all set correctly? Sorry but you don't say whether you are using the authoring tool or the framework so it's hard for me to advise on how to apply those correctly.

That component is owned by Learning Pool so hopefully someone from there maybe able to help if you're still stuck.

Picture of Brian Quinn
Re: iFrames and IE11
by Brian Quinn - Friday, 20 January 2017, 10:45 AM


I don't believe this is an issue with the Responsive Iframe component itself, but IE issues with the inview library (where the code in your screenshot comes from) have been fixed in the newly released 2.0.16 version of the framework.

Let me know if a full re-build using the latest version of the framework solves it for you.




Picture of Amy Palmer
Re: iFrames and IE11
by Amy Palmer - Monday, 23 January 2017, 9:58 AM

Hi Matt, Brian, 

Thanks for getting back to me! 

Just re-built the course using the latest version of the framework- still no luck! I'm getting the same error when I try it in IE11 (still works fine in Chrome and Firefox).

Matt- I am using the Framework, not the Authoring Tool. I have set the width and height in the component, it looks like this:


Have I got the width and height wrong? These were the default values in the example.json.