Picture of Mick  Leyden
Re: Error when migrating from Windows to Linux
by Mick Leyden - Wednesday, 10 May 2017, 7:39 AM

Hey Tom,

Thanks for the reply. I think you are on the right track. 

I was using the freshly installed config.json, I dont remember copying the temp folder but I noticed a mismatch in there. In the screenshot above it is trying to output to 58bf5a884780032016afaa5a.

I checked the config and it had: 590c06c8b55e7ab118622399 set as the tenant master ID. I then had a look in the temp folder in the VM and it did have a folder for both of those IDs but the 590cxxxx folder did not have any of the custom extensions or themes in the SRC folder. 

I thought, you beauty, I have found the problem. So I uploaded the missing extensions tried again and it was still no good. I was then struck by the fact the console was reporting the error on the 58fbxxx folder. So I updated config.json to show 58bf5a884780032016afaa5a, as the tenant master. Which is what the tenant master was on the windows folder, I then made sure all menus and extensions were present in the SRC folder... and I still get the same error, only this time I get it with all courses including freshly created courses!

So where I have got to now, the MasterTenantID in config.json is now the same as the windows installation. It is also the same as the folder that the authoring tool is attempting to output too. It also matches the Tenant ID recorded in the tenants table of the database (I just found that now). 

However new courses that have not been imported are no longer working since I have changed the TennantID from 59xxx. 

While writing this, I thought perhaps if I change everything, including the database back to the original tenant ID from config.json (590cxxxx), I might have more success. But when I try to edit it in Studio3T it tells me that field cannot be changed. 

Any other ideas? 


...as an aside, I must confess, I have been using adapt for 12 months or so and have thought many times, why the hell don't they just make an import export feature?!?!.... I am now beginning to understand! It is a lot more complex than I thought!