Picture of Mark Dunkerton
Install issues on Win 7 Enterprise
by Mark Dunkerton - Thursday, 7 September 2017, 12:24 AM

I'm trying to install the authoring tool on a Windows 7 Enterprise laptop.  I tried installing using directions at https://github.com/adaptlearning/adapt_authoring/wiki/Install-on-Server but got errors so I tried installing again (after uninstalling everything) using directions at https://github.com/adaptlearning/adapt_authoring/wiki/Install-Pre-requisites-on-Windows-Systems. This one was a bit different in terms of the steps but returned the same results.  Errors captured in npm-debug.log which I have attached for reference.  Not sure where I'm going wrong.  It seems everything works fine until the very last step of installing adapt-cli.  I'm getting all the pre-requisite programs from links so I'd assume they are the latest despite what the log is implying.

Picture of John Niezen
Re: Install issues on Win 7 Enterprise
by John Niezen - Thursday, 7 September 2017, 6:30 AM

Hi Mark,

try the steps from this posting: https://community.adaptlearning.org/mod/forum/discuss.php?d=1769&parent=8063

If I read your log correct, at the end it complains about the lifecycle scripts. I had a similar experience, and for me the legacy usage solved my problem (be it on Ubuntu)


Picture of Mark Dunkerton
Re: Install issues on Win 7 Enterprise
by Mark Dunkerton - Monday, 11 September 2017, 7:22 PM

Unfortunately there weren't any parallels with their issues that I could see, but that may be my lack of Ubuntu knowledge and the commands that go along with a Linux install.  However, I did manage to get it working.  Turns out I missed the note about making sure I was running Node vs 4.2.2.  Since I installed the latest of everything I thought I was good, but I had to use Nodist to downgrade Node to 4.2.2.  Once I did that it worked.