Picture of James Wan
assessment banks not functioning
by James Wan - Friday, 26 January 2018, 11:46 AM

Dear all,

I am using the Authoring tool and have created a course with an assessment. the assessment has 27 questions, i have created 5 question banks (by allocating numbers to the question bank id for each question). i then enabled the question bank and as a test i split the questions like so: 1,1,1,1,1


this should pull through 5 questions... or am i incorrect?


i then preview the course and when i select the assessment section, nothing happens. i accessed the browser developer tools and i do see an error. Please see attachment. I would appreciate some assistance. Thank you. 



Picture of Matt Leathes
Re: assessment banks not functioning
by Matt Leathes - Friday, 26 January 2018, 1:16 PM

Yes your understanding is correct.

I would check that:

  • you definitely have 5 question banks configured
  • they are all in the same article
  • they all have a question bank id assigned
  • that each question bank id is uniquely-named
Picture of Shaneshwar Bhagat
Re: assessment banks not functioning
by Shaneshwar Bhagat - Wednesday, 18 March 2020, 7:03 AM

Hi Matt,

Please clear my doubt with same. If I am creating 9 questions in same article and in that article if I took 3 bankID with 3 question each(i.e from total 9 questions, _quizBankID: 1  is having 3 question,  _quizBankID: 2 is having 3 question and  _quizBankID: 3 with 3 questions) If I use Split(3,2,1) then on my screen their should be total 6 question. am I right?

But If I am using this then on my screen it shows all 9 questions and only randomization is working. Why so?

I tried inserting  bank inside Article's assessment object and also outside of assessment object but it is not showing what I understood.

"_banks ":{
Picture of Matt Leathes
Re: assessment banks not functioning
by Matt Leathes - Wednesday, 18 March 2020, 11:20 AM

Hi Shaneshwar

I can assure you this works because I just tried it:

Unfortunately you don't say what version of the Framework/assessment you are using - but I am using the Framework 'master' branch and Assessment v4.0.0

My assessment article configuration looks like this: