Picture of lulu beber
can't install AAT on Azure Container Instances
by lulu beber - Monday, 3 December 2018, 4:58 PM

Hello everyone.

I've been testing AAT for sometime now on a local computer as a docker instance. I'm using this https://hub.docker.com/r/singularlearning/adapt_authoring/ and it works very well.

I'm now trying to migrate this installation to something more durable, and port it on Azure Container Instances.

and here is the problem :

I can start two Docker easily (one for Adapt, one for the mongoDB),  the installation of AAT runs well until the last step

"building web application"

this step runs for a while, and then I get disconnected from the docker instance


When I log back and try to run the server.js I have the error :

Error: /adapt_authoring/temp/adapt_framework/package.json: ENOENT: no such file or directory

so it seems the installation is not complete.


where can I find the log file of the installation ? I'm unable to understand what is wrong and where to look for further error message.

Is there a verbose mode for the installation ? so I could have more information

Thanks a lot for your help


Picture of Tom Taylor
Re: can't install AAT on Azure Container Instances
by Tom Taylor - Friday, 7 December 2018, 12:42 PM

The building web application bit is the final step of the installation, and is just a grunt process (see here). However, as you're also getting an ENOENT error, I'd suggest there's also something else wrong -- the path is missing a folder, which suggests that the master tenant hasn't been set up correctly. You should have something like:


Picture of lulu beber
Re: can't install AAT on Azure Container Instances
by lulu beber - Monday, 10 December 2018, 9:15 AM

Hello Tom, thx a lot for your answer

Indeed that should be a lead, I don't even have a "temp" folder in the adapt folder.


I check the log of the instance and i had a :

npm WARN grunt-mocha-test@0.13.3 requires a peer of mocha@>=1.20.0 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

so I tried to install, it, I also updated npm.

I can't install fsevents, but it is marked as optional so i guess it could run without it.

I ran another node Install.js and it seems that the tenant installation went fine (see picture below)

but again, the building failed and got me disconnected, and upon reconnection, the temp folder is gone.


I don't know where to look ...