Picture of Tom Greenfield
Can I use Adapt framework 4 in the authoring tool?
by Tom Greenfield - Thursday, 14 February 2019, 12:36 PM
 

Following today's 0.6.3 release of the authoring tool, yes, you can ūüéČ.

In this release, the authoring tool has been patched to pick up the configuration options available to the installed version of the framework. We currently only recommend installing framework 4 into new authoring tool setups, until a migration strategy has been decided for upgrading from previous versions.

To set up an authoring tool instance running framework 4, follow the usual install guide and during the node install section you'll receive the following prompt:

> Specific git revision to be used for the framework. Accepts any valid revision type (e.g. branch/tag/commit)

 Here, type the desired framework version in the form:

tags/v4.0.1

The list of available tag names may be found here.

Just to note that you need to be running a framework version of 2.0.14 or higher to use the 0.6.3 release of the authoring tool.

Picture of Matt Leathes
Re: Can I use Adapt framework 4 in the authoring tool?
by Matt Leathes - Thursday, 14 February 2019, 1:21 PM
 

Nice work!

Picture of Lars Halkjær
Re: Can I use Adapt framework 4 in the authoring tool?
by Lars Halkjær - Thursday, 14 February 2019, 8:06 PM
 

That is really great..! :D

One question though:
If I create a new 0.6.3 install with 4.0.1 framework, what happens if I import a course made on a 0.4.1/2.2.1 authoring tool?

Picture of Barry Jenkin
Re: Can I use Adapt framework 4 in the authoring tool?
by Barry Jenkin - Monday, 25 February 2019, 1:26 AM
 

I got an error when importing a course built using the previous AT/framework: 'Import version (2.3.3) not compatible with installed version (4.0.1)'.

Seems like AT 0.6.4 can only take advantage of 4.0.1 for the creation of brand new courses? I've had to stay with 0.6.4 / 2.3.3 for the meantime.

Picture of Matt Leathes
Re: Can I use Adapt framework 4 in the authoring tool?
by Matt Leathes - Monday, 25 February 2019, 10:19 AM
 

That's not entirely surprising. When we change the major version number for a release that's because that release contains 'breaking changes', necessitating some sort of intervention (usually in the .json files) in order to make your content work with the newer version.

In your case you're attempting to jump two major versions (v2.3.3 > v4.0.1) so will have two sets of breaking changes to overcome.

Picture of Barry Jenkin
Re: Can I use Adapt framework 4 in the authoring tool?
by Barry Jenkin - Monday, 25 February 2019, 10:12 PM
 

Should I try rolling back to an earlier framework version (perhaps v3), fixing whatever breaks, and moving up again from there if that's possible? Just wanting to avoid rebuilding a suite of courses or being left stranded on an old framework. 

Picture of Philip Roy
Re: Can I use Adapt framework 4 in the authoring tool?
by Philip Roy - Saturday, 16 February 2019, 2:41 AM
 

Oh that is fantastic news!