Picture of Jon Ewing
Authoring Tool: server does not "start listening"
by Jon Ewing - Tuesday, 21 July 2020, 6:09 PM

Hello all.

I am new to the Adapt Authoring tool and started off recently installing it on my own desktop PC, but now I want to put it on my network so others can start using it.

My Windows 10 local installation was successful and when I run "node server" I get a message saying "Server started listening on port 5000". In short, it works as intended.

However, I've just installed Adapt authoring tool 0.10.3 and Adapt framework 5.6.1 on Windows Server 2012 R2 Standard and when I navigate to the adapt_authoring directory and run "node server" it stops at the point where it lists the version numbers and does not display the line "Server started listening on port 5000". More importantly, it doesn't work. When I browse to localhost:5000 I just see a Bad Gateway page.

All of the requisite applications are the latest versions downloaded today (mongoDB 64-bit 4.2), Node.js 12.18.2 and grunt-cli v1.3.2.

The framework and authoring tool are install in a subdirectory of C:\inetpub\wwwroot so that I can hopefully add Adapt as a site in IIS if I can actually get it working. But one thing at a time!

Any ideas why it might not be working?

Picture of John Niezen
Re: Authoring Tool: server does not "start listening"
by John Niezen - Wednesday, 22 July 2020, 10:25 AM

might be silly to ask, but are you sure the MongoDB is running on your Server? And do you have the correct authorities to let the processes run?

Picture of Jon Ewing
Re: Authoring Tool: server does not "start listening"
by Jon Ewing - Wednesday, 22 July 2020, 11:17 AM

It's okay to ask. In fact, thank you for asking!

Yes MongoDB is definitely running as a local service and when I run "node server" it returns the status message "Connection established: adapt-tenant-master".

Like I say, I get exactly the same status responses on Windows 10 and Windows 2012 up until the Adapt framework version number. After that it should be telling me that it's listening on port 5000 but... nothing.

In answer to your other question, I don't know if I have the right authorities, but I have a subdirectory in inetpub/wwwroot running the Adapt framework on port 9001 and that works fine.

How would I know whether or not I have a permissions problem? I set everything up with the Administrator user and am logged into the server as Administrator via RDS when using the command line.

Picture of Sam Tsiu
Re: Authoring Tool: server does not "start listening"
by Sam Tsiu - Thursday, 23 July 2020, 2:55 AM

I can't be 100 certain but it seems to me your AAT app is stuck with the step of checking the updates of authoring tools and framework.

Check your server connection, perhaps?

Picture of Jon Ewing
Re: Authoring Tool: server does not "start listening"
by Jon Ewing - Thursday, 23 July 2020, 8:56 AM

That makes sense, Sam, but I don't think there's any connectivity problem. This is a web server that is constantly online. It was/is able to download the files to install Adapt Framework and Adapt Authoring, so presumably the updates come from the same source.

Picture of Simon Date
Re: Authoring Tool: server does not "start listening"
by Simon Date - Thursday, 23 July 2020, 1:51 PM

From what you described it does sound like a permission error.

Most Adapt users seem to run on Unix-based servers so it may be harder to get help for Windows servers.

I use Windows for local development and I've never had any issues myself.

Perhaps as on the Authoring tool Gitter room?

Picture of Jon Ewing
Re: Authoring Tool: server does not "start listening"
by Jon Ewing - Wednesday, 12 August 2020, 6:10 PM

At this stage I think I have taken one step forward and two back.

I completely uninstalled and reinstalled MongoDB and Node.js and then started afresh, installing the Adapt framework.

As before, the framework runs fine with the default course on port 9000.

But installing the adapt_authoring tool on Windows Server 2012 is just not working for me. I can now get slightly less close to completion than before - I have tried deleting and recreating the adapt-tenant-master database and running through the whole process multiple times but now it stalls every time it reaches the bit where it says “Now we need to configure the master tenant. Tip: just press ENTER to accept the default value in brackets”.

When I look at the database in Compass I can see that it only creates three collections - roles, sessions and users. These are created instantaneously. I have tried leaving it for up to an hour, just in case, but it never does anything after creating those first three collections.

Any suggestions? Maybe something I can do to ensure I do a completely clean uninstall and re-install? Anything I can look for in the Event Viewer that might give me a clue? I see nothing in the Event Viewer when I run "node install". Any known Windows Server issues that cause problems or conflicts with Adapt Authoring?

As I said before, the Adapt framework is working fine. And I have installed the framework and Authoring Tool successfully on Windows 10 on my network, so I am confident I am following the installation instructions correctly and to the letter, but when it doesn't work, I don't have enough information to make an informed decision about how to fix it.

Any suggestions welcome!