Picture of Andy Cranston
Re: Installing the Adapt Authoring Tool (AAT) on Windows Server 2019
by Andy Cranston - Wednesday, 23 September 2020, 7:57 AM
 

Thank you for your kind words James.

I have not got as far as accessing via the public web. However, here are some thoughts on what you might need to do:

  • If your AAT server is behind a firewall then some new firewall rules to allow access are probably required. I am not an expert in this area but a web search on "port forwarding" is probably a good start.
  • If your AAT server has its own firewall (Windows server does) you might need additional rules to allow access from hosts on other subnets and not just the local subnet.
  • Make sure your AAT server is fully "hardened" if it is being exposed to the internet. This would involve shutting down all but essential services and only letting through IP traffic from sources that absolutely need access.
  • Consider running the web service on port 443 (https) instead of port 80 (http) so traffic is encrypted. Look into getting a digital certificate.¬†https://letsencrypt.org/ is a good starting point.

As for the "system status... not authenticated" message. Is it the browser displaying this message or is it being output by the "node server" command? Either way is the other machine on the same or different subnet from the AAT server? Again firewall rules on the AAT server might have something to do with this. Also there might be configuration options in the node server change need to be changed.

-Andy.