Picture of Jonathan Briggs
Preview is blank with certain plugins
by Jonathan Briggs - Friday, 18 December 2020, 10:31 AM
 

[AT 0.10.5 | FW 5.8.0 | Mac OS 10.15.7 Catalina]

Getting back into Adapt after a short while away and I'm having trouble with certain plug-ins as I decided to start afresh with the latest AT and FW versions. Of course, generally it's when there's problems to sort with fw5 compatibility in the .less which I amend then it builds fine and there's no debug warnings in the AT… but the preview is simply blank. 

Console tells me:

'ReferenceError: can't find variable: factory' 

as per screenshot. So this is beyond my skillset frustratingly. In this case it's about the aut0poietic / adapt-lottie component and I realise there's open issues with it re fw 5 but is there a way forward on it that someone might share? It's coming up quite a lot with really useful plug-ins such as Search, Notes and so on.

Thanks

Jonathan 


Picture of Matt Leathes
Re: Preview is blank with certain plugins
by Matt Leathes - Friday, 18 December 2020, 12:00 PM
 

I think the soon-to-be-released v5.8.1 FW release will solve this. I'll try and get that out today.

FYI as a general rule in technology, if you want to play it safe, always wait for the dot-one release ;-)

(It doesn't matter how much testing you do locally, there will always be bugs that only show up when you release a new feature into the wild...)

Picture of Matt Leathes
Re: Preview is blank with certain plugins
by Matt Leathes - Friday, 18 December 2020, 12:42 PM
 

https://github.com/adaptlearning/adapt_framework/releases/tag/v5.8.1

Picture of Simon Date
Re: Preview is blank with certain plugins
by Simon Date - Saturday, 16 January 2021, 1:19 PM
 

Hi Matt,

This component doesn't seem to be working on >= v5.8.1. I've tested on v5.9.0 and still get the same issues.

Picture of Matt Leathes
Re: Preview is blank with certain plugins
by Matt Leathes - Monday, 18 January 2021, 10:17 AM
 

It's probably down 'strict mode' being enabled for JavaScript in v5.8.0 - v5.9.0. It'll be turned off in the next release.