Picture of Jason Wilson
New issue with links not opening in popup window anymore
by Jason Wilson - Thursday, 14 October 2021, 3:46 AM
 

Hi guys, we've discovered a new issue where text links set to open in a popup window no longer function correctly - they just go to the linked page in the same window as the course.

What is weird is if you click the links from within the Adapt author Tool back-end (where you can see them in the text area) they function correctly.

I've attached some screenshots to show that the popup JS "onclick" code no longer seems to get added to the link. I've also attached an error message we are now seeing in Chrome when clicking links.

I've also taken some screenshots to show you the back-end settings (which have always worked up until now).

Adapt authoring tool 0.10.5.

 Adapt framework v5.16.0

Note: the issue was actually first encountered by a team member running  Adapt framework v5.17.1 - I have yet to upgrade.

Chrome Version 94.0.4606.81 (Official Build) (64-bit) - also tested in firefox.
 
Apologies for the random order of screenshots!







Picture of Jason Wilson
Re: New issue with links not opening in popup window anymore
by Jason Wilson - Monday, 18 October 2021, 1:15 AM
 

So no one is having this issue?

 

I've also found that if the link works okay, and then you publish to SCORM, and then try to preview it again, the link doesn't work correctly.

Picture of Jason Wilson
Re: New issue with links not opening in popup window anymore
by Jason Wilson - Monday, 18 October 2021, 4:27 AM
 

Me again! I've just installed a fresh copy of the Adapt Author Tool on a different PC, and can confirm this issue exists immediately after installation (without any additional customisations, plugins, etc.).

I should've added in my original post that I'm on Windows 10 Pro 21H1.

Any fix would greatly be appreciated! :)