Picture of Phillip Harper
Help With An Error When Uploading to LMS - duplicate value for 'id'
by Phillip Harper - Friday, 12 April 2024, 6:45 PM


I am new to this and just started using the Authoring Tool. 

On my first project, the LMS (KnowBe4) is throwing this error when I attempt to upload and test the SCORM 2004 package: 

Unable to set cmi.objectives.0.id to: '6617eb98a4583729c840e2c0' Error: 351 - General Set Failure LMS Error Info: attempting to create element with duplicate value for 'id'

I have tried disabling or enabling things in the SPOOR plugin to see if those change anything and it does not. Unless I completely disable it, that is. 

The nice folks at KnowBe4 are helping me out by uploading the package for me so I can use it in my trainings, but I will most certainly need to edit it and try it out several times. Not to mention the fact that I will have a lot of these trainings that need to be done in Adept, so I am wanting to see if I can find any help on this to save some time and effort. 

Does anyone know this error or have any idea of where I can look to correct it?

I should also mention that I am exporting it in SCORM 2004 because that is the only format the LMS accepts. I have tried exporting it without SPOR and using manual methods to convert it over to SCORM but that ends up being more work for the same error. 


Picture of Oliver Foster
Re: Help With An Error When Uploading to LMS - duplicate value for 'id'
by Oliver Foster - Friday, 12 April 2024, 7:44 PM